$re = '/spring-.*-\d\.\d.xsd/';
$str = 'spring-beans-2.3.xsd
spring-beans-3.0.xsd
spring-beans.xsd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);