// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:25(?:25|10|5)|10(?:25|10(?:5(?:25|5|10)|25|10)|5(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10)))|5(?:25|10(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10))|5(?:25|10(?:5(?:25|5|10)|25|10)|5(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10)))))(?:25|10|5)*$").unwrap();
let string = "55555555555";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}