import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:25(?:25|10|5)|10(?:25|10(?:5(?:25|5|10)|25|10)|5(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10)))|5(?:25|10(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10))|5(?:25|10(?:5(?:25|5|10)|25|10)|5(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10)))))(?:25|10|5)*$";
final String string = "55555555555";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}