// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<street>\d+\s.*?(?:,\s*\w*\s*\d+)*),\s*(?P<city>.*?),\s*(?P<state>[A-Za-z]+)\s*(?P<zip>\d+)?,*").unwrap();
let string = "9320 Se Woodstock Blvd, Portland, OR 97266
921 S E Powell Blvd, PORTLAND, OR 97202
6560 Sw Beaverton, Raleigh Hills, OR 97225
2875 Se Powell Blvd, Portland, Or 97202, Usa
1311 Nw 23rd Ave, Portland, OR 97210
7710 Sw Barbur Blvd, Portland, OR 97219
1462 Ne 122nd Ave., Portland, OR 97230
1831 W Burnside, PORTLAND, OR 97209
1881 Sw 5th Ave, Portland, OR 97201
3610 Se Hawthorne Blvd, Portland, OR 97214
1850 Sw Skyline Blvd., Portland, OR 97221
9 Centerpointe Dr, Lake Oswego, OR 97035
7700 Southwest Dartmouth Avenue, 120, Tigard, OR 97223
4811 Meadows Road , Suite 111, Lake Oswego, OR 97035";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}