#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<street>\d+\s.*?(?:,\s*\w*\s*\d+)*),\s*(?P<city>.*?),\s*(?P<state>[A-Za-z]+)\s*(?P<zip>\d+)?,*"
Local $sString = "9320 Se Woodstock Blvd, Portland, OR 97266" & @CRLF & _
"921 S E Powell Blvd, PORTLAND, OR 97202" & @CRLF & _
"6560 Sw Beaverton, Raleigh Hills, OR 97225" & @CRLF & _
"2875 Se Powell Blvd, Portland, Or 97202, Usa" & @CRLF & _
"1311 Nw 23rd Ave, Portland, OR 97210" & @CRLF & _
"7710 Sw Barbur Blvd, Portland, OR 97219" & @CRLF & _
"1462 Ne 122nd Ave., Portland, OR 97230" & @CRLF & _
"1831 W Burnside, PORTLAND, OR 97209" & @CRLF & _
"1881 Sw 5th Ave, Portland, OR 97201" & @CRLF & _
"3610 Se Hawthorne Blvd, Portland, OR 97214" & @CRLF & _
"1850 Sw Skyline Blvd., Portland, OR 97221" & @CRLF & _
"9 Centerpointe Dr, Lake Oswego, OR 97035" & @CRLF & _
"7700 Southwest Dartmouth Avenue, 120, Tigard, OR 97223" & @CRLF & _
"4811 Meadows Road , Suite 111, Lake Oswego, OR 97035"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")