// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]{6}[0-9LMNPQRSTUV]{2}[ABCDEHLMPRST]{1}([1-9]|[12][0-9]|3[01]|4[1-9]|[56][0-9]|7[01]|LMNPQRSTUV){2}[A-Z]{1}[0-9LMNPQRSTUV]{3}[A-Z]{1}").unwrap();
let string = "MSLNDR00M19H501I
CNTMNL62C69H501O";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}