using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]{6}[0-9LMNPQRSTUV]{2}[ABCDEHLMPRST]{1}([1-9]|[12][0-9]|3[01]|4[1-9]|[56][0-9]|7[01]|LMNPQRSTUV){2}[A-Z]{1}[0-9LMNPQRSTUV]{3}[A-Z]{1}";
string input = @"MSLNDR00M19H501I
CNTMNL62C69H501O";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}