re = /^1?[\s-]?(\(\d{3}\)|\d{3})[\s-]?\d{3}[\s-]?\d{4}$/m
str = '1555 555 5555
5555555555
1-555-555-5555
1-(555)-555-5555
1(555) 555 5555
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end