package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^1?[\s-]?(\(\d{3}\)|\d{3})[\s-]?\d{3}[\s-]?\d{4}$`)
var str = `1555 555 5555
5555555555
1-555-555-5555
1-(555)-555-5555
1(555) 555 5555
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}