re = /(?P<type>deb(?:-src)?) (?:\[(?P<options>.*)\] )?(?P<uri>(?P<protocol>(?:(?:mirror\+)?(?P<local>file|cdrom|copy)|(?P<remote>http|https|ftp|ssh))):(?(remote)\/\/((?:(?!-)[a-zA-Z0-9-]{1,63}(?<!-)\.)+[a-zA-Z]{2,6}))\/[a-zA-Z0-1-_\.\/]+) (?P<suite>[a-z\/]+)(?:(?<!\/) (?P<components>[a-z]+(?: [a-z]+)*))/
str = 'deb [signed-by=path] http://de.archive.ubuntu.com/ubuntu/ focal main universe restricted'
# Print the match result
str.match(re) do |match|
puts match.to_s
end