// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z0-9\-]+)(\s+|-)").unwrap();
let string = "251-dash webm audio only | 3.18MiB 145k dash | audio only opus 145k 48k DASH audio, webm_dash
140 m4a audio only 2 | 3.07MiB 129k https | audio only mp4a.40.2 129k 44k medium, m4a_dash
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}