$re = '/^([a-zA-Z0-9\-]+)(\s+|-)/m';
$str = '251-dash webm audio only | 3.18MiB 145k dash | audio only opus 145k 48k DASH audio, webm_dash
140 m4a audio only 2 | 3.07MiB 129k https | audio only mp4a.40.2 129k 44k medium, m4a_dash
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);