$re = '/^(.*;.*){4,}$/m';
$str = 'a;b;c;d
e;f;g;h
i;;j;k;l
m;n;o;p';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);