package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*;.*){4,}$`)
var str = `a;b;c;d
e;f;g;h
i;;j;k;l
m;n;o;p`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}