$re = '/(?<a1>\"RJG1975\%\")/m';
$str = '$pwd = "RJG1975%"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);