$re = '/(?<formula>[A-Za-z0-9]\w+)(?<charge>[+-\s]*)(\((?<state>[^\)]*)\))?/';
$str = 'HBr-(g)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);