using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<formula>[A-Za-z0-9]\w+)(?<charge>[+-\s]*)(\((?<state>[^\)]*)\))?";
string input = @"HBr-(g)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}