import Foundation
let pattern = #"(?:(\?=)|)(?:(?:( |\n|\r\n)|)(?:( |\t)|)|)(?: |)(=)(?:[A-Za-z0-9].*|)(\?(UTF|utf)\-8\?)([A-Za-z0-9]\?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
?=
=?UTF-8?Q?
?=
=?UTF-8?Q?
=3D?UTF-8?Q?
=3D?UTF-8?Q?
=?UTF-8?Q?
=?UTF-8?Q?
?= =?UTF-8?Q?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)