re = /(?:(\?=)|)(?:(?:( |\n|\r\n)|)(?:( |\t)|)|)(?: |)(=)(?:[A-Za-z0-9].*|)(\?(UTF|utf)\-8\?)([A-Za-z0-9]\?)/m
str = '?=
=?UTF-8?Q?
?=
=?UTF-8?Q?
=3D?UTF-8?Q?
=3D?UTF-8?Q?
=?UTF-8?Q?
=?UTF-8?Q?
?= =?UTF-8?Q?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end