$re = '/from:\s*"+\s*[a-zA-Z]*+\s*"\s*,\s*to:\s*"\s*alice*\s*"\s*,\s*content:\s*"\s*[a-zA-Z]*\s*"\s*/m';
$str = 'from: "Sender", to: "alice", content: "Payload"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);