const regex = /from:\s*"+\s*[a-zA-Z]*+\s*"\s*,\s*to:\s*"\s*alice*\s*"\s*,\s*content:\s*"\s*[a-zA-Z]*\s*"\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('from:\\s*"+\\s*[a-zA-Z]*+\\s*"\\s*,\\s*to:\\s*"\\s*alice*\\s*"\\s*,\\s*content:\\s*"\\s*[a-zA-Z]*\\s*"\\s*', 'gm')
const str = `from: "Sender", to: "alice", content: "Payload"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}