$re = '/\b([0-9]){1,3}.([0-9]){1,3}.([0-9]){1,3}.([0-9]){1,3}$\b/m';
$str = '192.168.81.591
123.321.12.321
172.123.122.123
123.123.123.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);