import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([0-9]){1,3}.([0-9]){1,3}.([0-9]){1,3}.([0-9]){1,3}$\\b";
final String string = "192.168.81.591\n"
+ "123.321.12.321\n"
+ "172.123.122.123\n"
+ "123.123.123.123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}