import Foundation
let pattern = #"(?<=;charge=)([^-]+?)(?=&lang=en&pt=0&w=)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}