$re = '/(?<=;charge=)([^-]+?)(?=&lang=en&pt=0&w=)/m';
$str = 'https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);