$re = '/(Never gonna ((give you up)|(let you down)|(run around and desert you)|(make you cry)|(say goodbye)|(tell a lie and hurt you)))+/m';
$str = 'Never gonna give you up
Never gonna let you down
Never gonna run around and desert you
Never gonna make you cry
Never gonna say goodbye
Never gonna tell a lie and hurt you
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);