#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Never gonna ((give you up)|(let you down)|(run around and desert you)|(make you cry)|(say goodbye)|(tell a lie and hurt you)))+"
Local $sString = "Never gonna give you up" & @CRLF & _
"Never gonna let you down" & @CRLF & _
"Never gonna run around and desert you" & @CRLF & _
"Never gonna make you cry" & @CRLF & _
"Never gonna say goodbye" & @CRLF & _
"Never gonna tell a lie and hurt you" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")