using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(?: +|\t+)\+ *(?:VAR|CONST) *\w+ *=.*(?:\R^(?> +|\t+)[^+\s].*)*";
string input = @" + VAR name1 = var indented by two spaces and the first nonspace character is '+'
+ VAR name2 = var indented by 2x2 spaces
+ VAR name3 = var indented by one \t
+ VAR name4 = the next line with ""name5"" is not valid. missing the = character, should not be matched
+ VAR name5
+ CONST name6 = the type could be VAR or CONST
+ VAR multi1 = multiline value where the continuation lines
are indented (starts with two spaces or one tab) and NOT followed by the '+'
+ VAR multi1 = multiline value
indented
+ VAR multi1 = multiline value
indented ok too
+ VAR single = this is single line
+ because this line even if it is indented, the first nonspace character is '+'
+ VAR multi2 = multiline
could be
indented
any way
and any number of times
until the first non-indented line
the following should NOT match
+ VAR some = sould not be matched, because the line isn't indented
+ VAR some = sould not be matched, because the line isn't indented at least with TWO spaces or one tab
+ SOME name = value not matched because the SOME isn't VAR or CONST";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}