#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?: +|\t+)\+ *(?:VAR|CONST) *\w+ *=.*(?:\R^(?> +|\t+)[^+\s].*)*"
Local $sString = " + VAR name1 = var indented by two spaces and the first nonspace character is '+'" & @CRLF & _
" + VAR name2 = var indented by 2x2 spaces" & @CRLF & _
"" & @CRLF & _
" + VAR name3 = var indented by one \t" & @CRLF & _
" + VAR name4 = the next line with "name5" is not valid. missing the = character, should not be matched" & @CRLF & _
" + VAR name5" & @CRLF & _
" + CONST name6 = the type could be VAR or CONST" & @CRLF & _
"" & @CRLF & _
" + VAR multi1 = multiline value where the continuation lines" & @CRLF & _
" are indented (starts with two spaces or one tab) and NOT followed by the '+'" & @CRLF & _
"" & @CRLF & _
" + VAR multi1 = multiline value" & @CRLF & _
" indented" & @CRLF & _
"" & @CRLF & _
" + VAR multi1 = multiline value" & @CRLF & _
" indented ok too" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" + VAR single = this is single line" & @CRLF & _
" + because this line even if it is indented, the first nonspace character is '+'" & @CRLF & _
"" & @CRLF & _
" + VAR multi2 = multiline" & @CRLF & _
" could be" & @CRLF & _
" indented" & @CRLF & _
" any way" & @CRLF & _
" and any number of times" & @CRLF & _
" until the first non-indented line" & @CRLF & _
"" & @CRLF & _
"the following should NOT match" & @CRLF & _
"" & @CRLF & _
"+ VAR some = sould not be matched, because the line isn't indented" & @CRLF & _
" + VAR some = sould not be matched, because the line isn't indented at least with TWO spaces or one tab" & @CRLF & _
" + SOME name = value not matched because the SOME isn't VAR or CONST"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")