import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<[^>]*>|.cs[^\\}]*\\})";
final String string = "<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\" \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd\">\n"
+ "<html xmlns=\"http://www.w3.org/1999/xhtml\">\n"
+ " <head>\n"
+ " <meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\" /><title>\n"
+ " </title>\n"
+ " <style type=\"text/css\">\n"
+ " .csC583D0C8{text-align:left;text-indent:0pt;margin:12pt 0pt 12pt 0pt}\n"
+ " .csCABEF5ED{color:#282832;background-color:transparent;font-family:Arial;font-size:10pt;font-weight:bold;font-style:normal;}\n"
+ " </style>\n"
+ " </head>\n"
+ " <body>\n"
+ " <p class=\"csC583D0C8\"><span class=\"csCABEF5ED\">Test row 1<br/>Test row2</span></p></body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}