#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<[^>]*>|.cs[^}]*})"
Local $sString = "<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">" & @CRLF & _
"<html xmlns="http://www.w3.org/1999/xhtml">" & @CRLF & _
" <head>" & @CRLF & _
" <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><title>" & @CRLF & _
" </title>" & @CRLF & _
" <style type="text/css">" & @CRLF & _
" .csC583D0C8{text-align:left;text-indent:0pt;margin:12pt 0pt 12pt 0pt}" & @CRLF & _
" .csCABEF5ED{color:#282832;background-color:transparent;font-family:Arial;font-size:10pt;font-weight:bold;font-style:normal;}" & @CRLF & _
" </style>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <p class="csC583D0C8"><span class="csCABEF5ED">Test row 1<br/>Test row2</span></p></body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")