re = /\bAmazon\b(?!(?:(?!<\/?a\b[^>]*>).)*?<\/a>)/m
str = '<a>Amazon</a>Amazon
I use Amazon for that.
I use <a href="http://www.amazon.com">Amazon</a> for that.
<a href="http://www.amazon.com">My Amazon Link</a>
It will match the "Amazon" in "My Amazon Link"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end