$re = '/\bAmazon\b(?!(?:(?!<\/?a\b[^>]*>).)*?<\/a>)/m';
$str = '<a>Amazon</a>Amazon
I use Amazon for that.
I use <a href="http://www.amazon.com">Amazon</a> for that.
<a href="http://www.amazon.com">My Amazon Link</a>
It will match the "Amazon" in "My Amazon Link"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);