// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b([01]?[0-9]|2[0-3]):([0-5][0-9])(?::([0-9][0-9]))?\b").unwrap();
let string = "02:33
2:33
12:22:32
The time is 23:33
it's12:34
12:33:34455
44:45
25:50:02
18:78
2A:3E:EE
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}