$re = '/\b([01]?[0-9]|2[0-3]):([0-5][0-9])(?::([0-9][0-9]))?\b/m';
$str = '02:33
2:33
12:22:32
The time is 23:33
it\'s12:34
12:33:34455
44:45
25:50:02
18:78
2A:3E:EE
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);