package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d)x(\d+)\)`)
var str = `A(1x5)BC
ADVENT
A(1x5)BC
(3x3)XYZ
A(2x2)BCD(2x2)EFG
(6x1)(1x3)A
X(8x2)(3x3)ABCY
1x5)BC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}