#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d)x(\d+)\)"
Local $sString = "A(1x5)BC" & @CRLF & _
"ADVENT" & @CRLF & _
"A(1x5)BC" & @CRLF & _
"(3x3)XYZ" & @CRLF & _
"A(2x2)BCD(2x2)EFG" & @CRLF & _
"(6x1)(1x3)A" & @CRLF & _
"X(8x2)(3x3)ABCY" & @CRLF & _
"1x5)BC"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")