// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)([a-zA-Z_]\w+|[a-zA-Z]\w*|\[\s*[a-zA-Z_]\w+\s*\]|\[\s*[a-zA-Z]\w*\s*\])\s*\[\s*['"]([a-zA-Z_]\w+|[a-zA-Z]\w*)['"]\s*\]"#).unwrap();
let string = "a['b'][c]
a['1']
a['b1']
a[1]
a['_'] --I am pretty sure this is bad to match
a[\"__\"] --idk if this is bad to match
a[\"_ _\"]
a[\"up\"]
a[\"up \"]
a['b']['c'] --notice how this doesn't match the first quote with the last one
a[\"workwork\"]
_adf [ 'test' ] --even when imporoperlly formated this is valid lua
a.[b] [\"yup\"] --this case preserves the [b] and will append .yup after it
a[\"a.basdf\"]
\"adlfkajsd.dklajdlakj\"";
let substitution = "$1.$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}