import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z_]\\w+|[a-zA-Z]\\w*|\\[\\s*[a-zA-Z_]\\w+\\s*\\]|\\[\\s*[a-zA-Z]\\w*\\s*\\])\\s*\\[\\s*['\"]([a-zA-Z_]\\w+|[a-zA-Z]\\w*)['\"]\\s*\\]";
final String string = "a['b'][c]\n"
+ "a['1']\n"
+ "a['b1']\n"
+ "a[1]\n"
+ "a['_'] --I am pretty sure this is bad to match\n"
+ "a[\"__\"] --idk if this is bad to match\n"
+ "a[\"_ _\"] \n"
+ "a[\"up\"]\n"
+ "a[\"up \"]\n"
+ "a['b']['c'] --notice how this doesn't match the first quote with the last one\n"
+ "a[\"workwork\"]\n"
+ "_adf [ 'test' ] --even when imporoperlly formated this is valid lua\n"
+ "a.[b] [\"yup\"] --this case preserves the [b] and will append .yup after it\n"
+ "a[\"a.basdf\"]\n"
+ "\"adlfkajsd.dklajdlakj\"";
final String subst = "$1.$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}