import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0|[1-9]+[0-9]*) (@[^@]+@ |)([A-Za-z0-9_]+)( [^\\n\\r]*|)$";
final String string = "0 @N1@ NOTE Lorem ipsum dolor sit amet\n"
+ "0 HEAD\n"
+ "1 SOUR FTM\n"
+ "2 VERS 22.2.6.950\n"
+ "1 DEST FTM\n"
+ "1 DATE 31 MAR 2017\n"
+ "1 CHAR UTF-8\n"
+ "3 _LINK http://www.facebook.com/1247584965\n"
+ "2 SOUR @S122@\n"
+ "3 PAGE Facebook update - David Hatch - 6/5/2013\n"
+ "3 _LINK http://www.facebook.com/1247584965\n\n\n"
+ "1 RESI\n"
+ "2 DATE BET 1935 AND 1993\n"
+ "2 PLAC San Francisco, California, USA\n"
+ "1 RESI\n"
+ "2 DATE 1994\n"
+ "2 PLAC San Francisco, California, USA\n"
+ "2 SOUR @S605@\n"
+ "3 DATA\n"
+ "4 TEXT Birth date: 20 Sep 1966 Birth place: Residence date: 1994 \n"
+ "5 CONC Residence place: San Francisco, CA\n"
+ "1 RESI 106 Oakcrest Rd\n"
+ "2 DATE 26 MAR 2017\n"
+ "2 PLAC San Anselmo, Marin, California, USA\n"
+ "1 FAMS @F500@\n"
+ "1 FAMC @F656@\n"
+ "0 @I923@ INDI\n"
+ "1 NAME Vincent /Crilley/\n"
+ "1 SEX M\n"
+ "1 FAMS @F254@\n"
+ "0 @I5899@ INDI\n"
+ "1 NAME Marjorie Edna /Footitt/\n"
+ "2 SOUR @S506@\n"
+ "2 SOUR @S176@\n"
+ "2 SOUR @S168@\n"
+ "2 SOUR @S624@\n"
+ "3 DATA\n"
+ "4 TEXT Residence date: Residence place: USA\n"
+ "2 SOUR @S115@\n"
+ "3 PAGE Year: 1940; Census Place: St Paul, Ramsey, Minnesota; Roll: T627_1996; \n"
+ "4 CONC Page: 11A; Enumeration District: 90-73.\n"
+ "3 DATA\n"
+ "4 _TEXT Birth date: abt 1918 Birth place: North Dakota Residence date: 1 \n"
+ "5 CONC Apr 1940 Residence place: St Paul, Ramsey, Minnesota, United States\n"
+ "2 SOUR @S607@\n"
+ "3 PAGE Year: 1920; Census Place: Carrington, Foster, North Dakota; Roll: \n"
+ "4 CONC T625_1334; Page: 13B; Enumeration District: 117; Image: .\n"
+ "3 DATA";
final String subst = "\\n2($2) 3($3) 4($4) 5($5) 6($6) 7($7) \\n\\n8($8) 9($9) 10($10) 11($11) 12($12) 13($13) 14($14) 15($15) 16($16) 18($18) 20($20) 21($21)\\n\\n\\n\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}