$re = '/there is an audit log entry for user (\w*)?(?: with DA logType) ?(Pending|Approved)?/';
$str = 'there is an audit log entry for user maker with DA logType Approved';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);