package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`there is an audit log entry for user (\w*)?(?: with DA logType) ?(Pending|Approved)?`)
var str = `there is an audit log entry for user maker with DA logType Approved`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}