use strict;
my $str = 'Falls Church VA 23112
Arlington Virginia 24221-2345
Arlington VIRGINIA 24221-2345
TYSON CORNER VA 232342345';
my $regex = qr/(?<City>.*)\s[^\s]+\s[0-9\-]{5,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}