#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<City>.*)\s[^\s]+\s[0-9\-]{5,}"
Local $sString = "Falls Church VA 23112" & @CRLF & _
"Arlington Virginia 24221-2345" & @CRLF & _
"Arlington VIRGINIA 24221-2345" & @CRLF & _
"TYSON CORNER VA 232342345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")