$re = '/^.{19}\K(?:needle)/m';
$str = 'needle and another needle
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);