const regex = /^.{19}\K(?:needle)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.{19}\\K(?:needle)', 'm')
const str = `needle and another needle
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}