re = /^\/(el|en)\/categories\/(.*)\/(.*)$/
str = '/el/categories/keik-mpiskota/ta-melomakarona-toy-akh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end