package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^/(el|en)/categories/(.*)/(.*)$`)
var str = `/el/categories/keik-mpiskota/ta-melomakarona-toy-akh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}