const regex = /(--)[^\,\:\)]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(--)[^\\,\\:\\)]+', 'g')
const str = `.btn { --padding-top: var(--btn-padding-top, 0.5em); --padding-right: var(--btn-padding-right, 1.5em); --padding-bottom: var(--btn-padding-bottom, 0.5em); --padding-left: var(--btn-padding-left, 1.5em); --color: var(--btn-color, #444); --background-color: var(--btn-background-color, #E2E2E2); --font-size: var(--btn-font-size, 14px); --font-family: var(--btn-font-family, sans-serif); padding-top: var(--padding-top); padding-right: var(--padding-right); padding-bottom: var(--padding-bottom); padding-left: var(--padding-left); color: var(--color); background-color: var(--background-color); font-size: var(--font-size); font-family: var(--font-family); line-height: Calc(var(--font-size) + var(--padding-bottom) + var(--padding-top)); border: medium none; text-align: center; cursor: pointer; }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}