using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(--)[^\,\:\)]+";
string input = @".btn { --padding-top: var(--btn-padding-top, 0.5em); --padding-right: var(--btn-padding-right, 1.5em); --padding-bottom: var(--btn-padding-bottom, 0.5em); --padding-left: var(--btn-padding-left, 1.5em); --color: var(--btn-color, #444); --background-color: var(--btn-background-color, #E2E2E2); --font-size: var(--btn-font-size, 14px); --font-family: var(--btn-font-family, sans-serif); padding-top: var(--padding-top); padding-right: var(--padding-right); padding-bottom: var(--padding-bottom); padding-left: var(--padding-left); color: var(--color); background-color: var(--background-color); font-size: var(--font-size); font-family: var(--font-family); line-height: Calc(var(--font-size) + var(--padding-bottom) + var(--padding-top)); border: medium none; text-align: center; cursor: pointer; }";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}